Я попробую ваше предложение. Вы резюмировал это очень лаконично и да, это правда - полный ответ гораздо более долгую историю, чем выше! @Митч это обычная миграция Windows парадигмы - пользователи всегда предполагайте, что вы должны установить драйверы на Linux, потому что они так привыкли это делать в Windows, я изначально самостоятельно скомпилированные приложения, когда я начинал в Linux в 07 потому, что понятие системы управления пакетами было мне чуждо. Я думаю он (а)пытается найти некоторые документы о том, как писать областей 13.10 в Python. Насколько я вижу, на странице вы связаны только информацию о прицелы для 13.04 и раньше или другие языки программирования. Что это значит ОК. Но если ваш ответ "вы чувствуете, что вам нужно дополнительной графической мощности и готовы пожертвовать немного дополнительную энергию на это", - то я до сих пор в недоумении - я не хочу есть "чувство", когда мне нужны дополнительные ГПУ. Я надеялся, что там был какой-то объективный критерий, какие программы нужны - я ожидал, что можно было бы выяснить, если программа использует широко в OpenGL.

Когда я пытаюсь установить Firefox через "Центр приложений Ubuntu", он начинает применять изменения без необходимости предварительной загрузки пакетов и затем я получаю это сообщение:

Операции Пакет Не Удалось

Установка или удаление пакета не удалось

Детали:

 installArchives() не удалось: на Perl: предупреждение: установка локали не удалось.
на Perl: предупреждение: пожалуйста, убедитесь, что настройки локали:
 Язык = (отключенное),
 Lc_all = (отключенное),
 Ланг = "en_IN.Кодировка iso8859-1"
 поддерживаются и установленных на вашей системе.
на Perl: предупреждение: возврат к стандартной локали ("с").
языка: не удается установить lc_ctype для локали по умолчанию: нет такого файла или каталога
язык: невозможно установить для категории lc_messages для локали по умолчанию: нет такого файла или каталога
язык: не удается задать значение lc_all для локали по умолчанию: нет такого файла или каталога
на Perl: предупреждение: установка локали не удалось.
на Perl: предупреждение: пожалуйста, убедитесь, что настройки локали:
 Язык = (отключенное),
 Lc_all = (отключенное),
 Ланг = "en_IN.Кодировка iso8859-1"
 поддерживаются и установленных на вашей системе.
на Perl: предупреждение: возврат к стандартной локали ("с").
языка: не удается установить lc_ctype для локали по умолчанию: нет такого файла или каталога
язык: невозможно установить для категории lc_messages для локали по умолчанию: нет такого файла или каталога
язык: не удается задать значение lc_all для локали по умолчанию: нет такого файла или каталога
на Perl: предупреждение: установка локали не удалось.
на Perl: предупреждение: пожалуйста, убедитесь, что настройки локали:
 Язык = (отключенное),
 Lc_all = (отключенное),
 Ланг = "en_IN.Кодировка iso8859-1"
 поддерживаются и установленных на вашей системе.
на Perl: предупреждение: возврат к стандартной локали ("с").
языка: не удается установить lc_ctype для локали по умолчанию: нет такого файла или каталога
язык: невозможно установить для категории lc_messages для локали по умолчанию: нет такого файла или каталога
язык: не удается задать значение lc_all для локали по умолчанию: нет такого файла или каталога
на Perl: предупреждение: установка локали не удалось.
на Perl: предупреждение: пожалуйста, убедитесь, что настройки локали:
 Язык = (отключенное),
 Lc_all = (отключенное),
 Ланг = "en_IN.Кодировка iso8859-1"
 поддерживаются и установленных на вашей системе.
на Perl: предупреждение: возврат к стандартной локали ("с").
языка: не удается установить lc_ctype для локали по умолчанию: нет такого файла или каталога
язык: невозможно установить для категории lc_messages для локали по умолчанию: нет такого файла или каталога
язык: не удается задать значение lc_all для локали по умолчанию: нет такого файла или каталога
Выбор ранее выбранных пакет браузера Firefox.
(Чтение базы данных ... 
(Чтение базы данных ... 5%
(Чтение базы данных ... 10%
(Чтение базы данных ... 15%
(Чтение базы данных ... 20%
(Чтение базы данных ... 25%
(Чтение базы данных ... 30%
(Чтение базы данных ... 35%
(Чтение базы данных ... 40%
(Чтение базы данных ... 45%
(Чтение базы данных ... 50%
(Чтение базы данных ... 55%
(Чтение базы данных ... 60%
(Чтение базы данных ... 65%
(Чтение базы данных ... 70%
(Чтение базы данных ... 75%
(Чтение базы данных ... 80%
(Чтение базы данных ... 85%
(Чтение базы данных ... 90%
(Чтение базы данных ... 95%
(Чтение базы данных ... 100%
(Чтение базы данных ... 225197 файлы и каталоги установлены.)
Распаковка Firefox (начиная с .../firefox_20.0+build1-0ubuntu0.12.10.3_i386.деб) ...
Выбор ранее выбранных пакет браузера Firefox-globalmenu.
Распаковка и Firefox-globalmenu (С .../для Firefox-globalmenu_20.0+build1-0ubuntu0.12.10.3_i386.деб) ...
Обработка триггеров для bamfdaemon ...
Восстановление /usr/доли/приложения/фумб.индекс...
Обработка триггеры для desktop-файл-утилиты ...
Обработка триггеры для GNOME-меню ...
Обработка триггеры для MAN-DB с ...
языка: не удается установить lc_ctype для локали по умолчанию: нет такого файла или каталога
язык: невозможно установить для категории lc_messages для локали по умолчанию: нет такого файла или каталога
язык: не удается задать значение lc_all для локали по умолчанию: нет такого файла или каталога
Настройка Firefox (20.0+build1-0ubuntu0.12.10.3) ...
обновление-альтернатив: ошибка: альтернативный путь /usr/Бен/Firefox не существует
с dpkg: ошибка при обработке браузером Firefox (--настроить):
 подпроцесс установлен сценарий, выполняемый после установки вернул код ошибки 2
Нет отчета Аппорт написано, потому что MaxReports уже достиг 
с dpkg: проблемы зависимостей предотвратить конфигурации браузера Firefox-globalmenu:
 в Firefox-globalmenu зависит от браузера Firefox (= 20.0+build1-0ubuntu0.12.10.3); однако:
 Пакет Firefox-это еще не настроено.

с dpkg: ошибка при обработке в Firefox-globalmenu (--настроить):
 проблемы зависимостей - оставляем "не задано"
Нет отчета Аппорт написано, потому что MaxReports уже достиг 
Ошибки возникли при обработке:
в Firefox
в Firefox-globalmenu
Ошибка в функции: 
Настройка Firefox (20.0+build1-0ubuntu0.12.10.3) ...
обновление-альтернатив: ошибка: альтернативный путь /usr/Бен/Firefox не существует
с dpkg: ошибка при обработке браузером Firefox (--настроить):
 подпроцесс установлен сценарий, выполняемый после установки вернул код ошибки 2
с dpkg: проблемы зависимостей предотвратить конфигурации браузера Firefox-globalmenu:
 в Firefox-globalmenu зависит от браузера Firefox (= 20.0+build1-0ubuntu0.12.10.3); однако:
 Пакет Firefox-это еще не настроено.

с dpkg: ошибка при обработке в Firefox-globalmenu (--настроить):
 проблемы зависимостей - оставляем "не задано"

Примечание : Я пытался установить Firefox раньше, но он выдавал ошибку при загрузке, поэтому я скачал Firefox с официального сайта, и следовали инструкциям, которые я нашел на https://help.ubuntu.com/community/FirefoxNewVersion/MozillaBuilds Что позвольте мне использовать Firefox, но я тогда думал, что через один из ОСК будет лучше, так как он будет обновляться. Так что я удалил браузер Mozilla строить и попытался установить снова с ОСК, после чего я получил сообщение об ошибке выше. Я подозреваю, что моя попытка использовать встроенный в Mozilla может быть причиной ошибки.

ОК, Когда я вошел судо apt-получить установку для Firefox в терминале, я получил это:

судо apt-получить установку для Firefox
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Следующие пакеты были установлены автоматически и больше не требуется:
 freegish-данные gir1.2-переименовать-2.0 gir1.2-уникальный-libunique 3.0-3.0-0
 то ndiswrapper-общем то ndiswrapper-utils версии-1.9 на Python-compizconfig
Воспользоваться 'apt-получить autoremove', чтобы удалить их.
Следующие дополнительные пакеты будут установлены:
в Firefox-globalmenu
Предлагаемые пакеты:
 латекс-поддержкой xft-шрифты в Firefox-гном-поддержка
Следующие новые пакеты будут установлены:
 в Firefox в Firefox-globalmenu
Обновлено 0, 2 установлено новых, 0 для удаления, и 0 пакетов не обновлено.
Нужно получить 0 б/24.6 МБ архивов.
После этой операции, 51.7 МБ дополнительного дискового пространства будет использовано.
Вы действительно хотите продолжить [д/н]? г
Выбор ранее выбранных пакет браузера Firefox.
(Чтение базы данных ... 225197 файлы и каталоги установлены.)
Распаковка Firefox (начиная с .../firefox_20.0+build1-0ubuntu0.12.10.3_i386.деб) ...
Выбор ранее выбранных пакет браузера Firefox-globalmenu.
Распаковка и Firefox-globalmenu (С .../для Firefox-globalmenu_20.0+build1-0ubuntu0.12.10.3_i386.деб) ...
Обработка триггеров для bamfdaemon ...
Восстановление /usr/доли/приложения/фумб.индекс...
Обработка триггеры для desktop-файл-утилиты ...
Обработка триггеры для GNOME-меню ...
Обработка триггеры для MAN-DB с ...
Настройка Firefox (20.0+build1-0ubuntu0.12.10.3) ...
обновление-альтернатив: ошибка: альтернативный путь /usr/Бен/Firefox не существует
с dpkg: ошибка при обработке браузером Firefox (--настроить):
 подпроцесс установлен сценарий, выполняемый после установки вернул код ошибки 2
Е: суб-процесс /usr/бен/с dpkg вернул код ошибки(1)'

после чего я получил отчет об ошибке.